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Objectives — Week 3
By the end of this session you will be able to :-

Move around a worksheet

Recognise cell references

Sort data alphabetically

Insert rows and columns

Delete rows and columns

Use the Convert Text to Columns wizard
. Use Autofilter
. Add a header and footer to worksheets

Set print areas

Print Worksheets



Looking at Excel as a Database

Although Excel is mainly used for financial purposes it can be used to hold data in a similar
manner to a database. It is particularly useful for holding data for a mail merge or data that
requires some sorting, however it does not have the reporting capabilities of Access.

You have been asked to send letters to 10 students from 1010 tutor group.

Open the workbook named 1010 on the R: drive in the Excel folder. This workbook
contains address details for the tutor group 1010 that | have exported from SIMS.net.

Moving around the worksheet
- Use the arrow keys on the keyboard
- Use your mouse pointer (a white cross) to move to the cell required
- Use the horizontal and vertical scrollbars

Inserting Rows

Column headings are required so that when you print out the data it is clear or, if you use it
for a mail merge, the columns can be picked up as the merge fields.

- Toinsert a new row above row 1, put your cursor into any 21 e e vew [mser [ Fomst 1ok pata w
cell in row 1 and select Insert > Row from the menu bar. %' . EX%
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Using the Convert Text to Columns Wizard

You have probably noticed that the students' forenames and surnames are in one column.
It's a good idea to separate them into separate columns, especially for mail merge,
otherwise the names will be back to front! We can get Excel to split the data from column
A into more than one column, but unless we insert columns first the data in subsequent
columns will be overwritten.

- Toinsert a new column to the right of column A, put your cursor in any cell in
column B, and select Insert > Columns from the menu bar. This will insert a column
before the active column.

- Repeat the process until you have inserted 5 columns (Its always best to insert
more columns than you need and delete the extra ones later).
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Step 3

« You can now set the data format that your column
contains or decide not to import columns.

- You need to change the data type of columns 1 and
2 to text.

« Click on finish.

Now you can label the new columns:-

Convert Text to Columns Wizard - Step 3 of 3

This screen lets you select sach column and set

the Data Format.
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- Name columns A and B (Surname, Forename).

- Delete the blank columns — highlight all four blank
columns and select Edit > Delete.
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1 [Sumame Forenam Gender Year  Tutc
2 |Pearson Scott M Year 1011010
3 |Wheeldon Natalie F Year 1011010
T4lees  Rhurie M Year 10 11010
5 |Roman  Thomas M Year 10 11010
6 |Simpson  Hannah F Year 1011010
7 |Hasnip  Edward M Year 1011010
B |Elliott  Samantha] F Year10 11010
9 |wilson  Hollie F Year10 11010
TI0]|Revell  nicole F Year10 11010
T |Hough  Nicholas M Year10 71010
12|Russell  Robert M Year 10 71010
13 |Holness | Laura F Year 10 71010
14 |Gamer  Mark I Year 10 71010
15 |Coates  Dennis I Year 10 71010
1B |Cressey  Oliver I Year 10 71010
17 |Hodson  Robert I Year 10 71010
18| Brocklehur Henery M Year 10 1101
19 |CarmichaeLee I Year 10 11010
20 |Gibbons  Steven M Year 10 1010
21 |Howsen F Year 101010
22|Hussain _ Syed M Year 1011010
23 |Herbenth  Matthew i Year 1011010
24]Freeman _Francescd F Year 1011010
25 |Parker  Katring F Year 1011010
W 4 »r Hh\Sheetl,/ |«

For presentation purposes it would now be a good idea to resize the columns so you can

see all the text contained within them.

- Click in the grey box at the top left of the worksheet to highlight the whole

worksheet.

«  Move your cursor to the line between columns A and B, so you get the resize

cursor.

- Double click and your columns will resize to fit the data contained within them.

Your table should look like this:-
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_2 |Pearson  IScott Il ‘fear 10 (1010 br and hrs M Pearsan a Patterdale Drive
_3 |Wheeldon [ Matalie F ‘fear 10 (1010 izs M Wheeldan 15 Munnery Walk
4 |Lees Rhurie Il ‘fear 10 1010 Wirs F Lees 11 Trinity Grove
5 |Roman Thomas M ‘fear 10 (1010 Miss E Roman a5 Fairfield
_6 |Simpson Hannah F ‘fear 10 1010 kr and hrs S Simpson 94 WWestfield Park
_7 |Hasnip Edward hl Year 10 1010 Wr and Wirs P Hasnip 2] Lowerdale
_8 |Elliott Samantha F ‘fear 10 1010 br and hrs M Elliott i Jobsons Road
_9 |Wilsan Hollie F Year 10 1010 Mr M Wilson and Miss A Srith 38 Welton Old Road
_10 |Revell Micole F Year 10 1010 kr and Mrs C Revell 39 East Dale Road
_11 |Hough Micholas M Year 10 1010 hr and hrs L Hough 2] Plantation Drive
_12 |Russell Robert i Year 10 1010 tr and Mrs D Russell 5 Park Road
_13 |Holness Laura F Yfear 10 1010 r and Mrs R Holness 35 Common Lane
_14 |Garner Wark i Yfear 10 1010 tr and Mrs P Garner "9 Melton Battom
15 [Coates Dennis M ‘fear 10 1010 Mr R Coates 50 Marthdale Park
16 |Cressey Oliver Il ‘fear 10 1010 hirs L Cressey B2 tarket Place
17 |Hodsan Rabert Il ‘fear 10 (1010 kr and Mrs R Hodsan &0 Southfield Drive
18 |Brocklehurst Henery Il ‘fear 10 (1010 br and Mrs G Brocklehurst 40 Hurmber Road
19 [Carmichael |Lee ] ‘fear 10 (1010 Mr L Carmichael 2 Hally Hill
20|Gibbons  Steven ] ‘fear 10 (1010 Mrs S Granger 53 Husthuwaite Road
21 |Howson Samantha F ‘fear 10 1010 kr and Mrs D Howson B0 Lowerdale
22 |Hussain Syed hl Year 10 1010 Dr and Mrs S Muzaffar "B Stockbridge Road
23 |Herberth Matthew W Year 10 1010 Ms H Cooper Keel House Redcliffe Road
_24 |Freeman Francesca F Year 10 1010 br and Mrs A Freeman M2 Covington
25 |Parker Katrina F Yfear 10 1010 hrs Parker 79 Sorinofield Avenue ¥
W 4 » M) Sheetl/ <
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Using the Autofilter

You have been given a list of ten students from the tutor group to send letters to. In order
to only send letters to those students you need to delete the others. The easiest way to do
this is to indicate on the worksheet which students details you want to keep and delete the

others using Autofilter.

Insert a blank column before column A.
Using the list of students below put a Y into the new column (now called column A)
for each student listed.

+ Robert Russell

- Robert Hodson

- Syed Hussain

- Katrina Parker

« Henery Brocklehurst
- Shauna Briggs

« Francesca Freeman

- Sophie Mann

- Samantha Howson
Edward Hasnip
nghllght the whole worksheet

Select Data > Filter > Autofilter from the menu bar | sy s
Arrow boxes will appear in the heading row of each _|

column.
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Sort Ascending arson Scott

Sort Descending celdon Natalie

(Al Es Rhurie

(Top 10...) man Thamas
Custom. pson Hannah
{Elanks) snip Edward
_{MorBlarks) ot Samantha
9 Wilson Hallie
10 Revell Micale
11 Hough Micholas
12y Russell Fobert
13 Holness Laura
14 Garner Mark
15 Coates Dennis
1B | Cressey Oliver
A7y Hodsan Robert
18w Rrnrklrhurst [Henary

You will now see the students you do notz z

In column A click on the arrow and
highlight Y to indicate that you
want to view only the students with
a Y in column A. You will see that
the arrow is now blue which
indicates there is a filter being

used in this column.
You will see only the ten
students you wish to
send letters to.

Click on the arrow in
column A again and this iz
time select Blanks.

wish to send letters to.

Highlight the rows by clicking and
dragging in the column where the row numbers are.
Select Edit > Delete Row from the menu bar to delete the details of the students
you do not want to send letters to.
Change the filter in column A to Al
Save the file to your desktop as “Student Letters”
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29y Brigys Shauna F Vear 10 1010 hr and Mrs T Brigos



Finishing touches and printing the worksheet

You will now see the details of the ten students required so you can use this for your mail
merge.

Copying Text

Looking in the County column you will see inconsistencies in the name used. To copy East
Riding of Yorkshire into all the cells in the County column:-
- Click into the first row that contains East Riding of Yorkshire
- Move the cursor to the bottom right of the cell (the cursor will change from an empty
white cross into a solid black cross)
- Hold down the left mouse button
- Drag the mouse down to the last cell you want East Riding of Yorkshire to appear in

Adding a Header and footer
Before printing a worksheet it is good practice to add a title in the header area.

- Select View > Header and Footer from the menu bar.

- Click on Custom Header b s el 5
. Click on the centre screen [ ®
- Type in the title “Students from 1010 for Mail | e e e ostenthe

Merge” B i o et i e P

cursor in the edit box and press the Format Pickure buttan,

- Make the text bold by using your mouse to
highlight the text

. Click on the font icon ([4]) and select Bold (you
could also change the font and size here too)

- Press OK 3 times
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Printing the Worksheet

Before clicking on the Print icon you need to set the print area of the worksheet to be
printed and look at the Print Preview to check the data fits to the number of pages you
req u | re . E1 Microsoft Excel - 1010_test

i) Bl | Edt Wew [nset Format Tools Data  window tel
i i i ;J 1 Mew.. Chrl+Hh “ﬂ @ !g,q”a\
- Click your mouse into the top left most cell to be printed — = > .
o County
(B1) Z|d s SoHS kst Riding of Yorkshira
3 Save As.. East Riding of Yorkshire
- Hold down the left mouse button P Era i Yot
B . H 5| E2 e Search.. ast Riding of Varkshire
- Drag diagonally to the bottom right most cell to be printed4 " ... s Yooe Rung of Vaonie
8 East Riding of Yorkshire
(K1 1 ) % s Reoperey) East E\Smg of Yorkshire
10 Page Setup... ast Riding of Yorkshire
. AU it avea Pl[ setrrincarea
Release the left button _ L s |
- Select File > Print Area > Set Print Area from the menu |4 er.
Send To 3
bar 7 | toe
. . . i 2 Ct\Documents and Settings|guest|Desk. .4 1010_test
- Select File > Print Preview from the menu bar ]|
% Exit
=l
A
24
1« 4 v ni\Sheet1/ <

Look at the preview. You will see that the worksheet is currently split [~ e o

onto two pages. To tidy it up:- O —

Scaling Options. ..

- Click on the Setup option Mty N
- On the Page tab change the orientation to Landscape and in | — .
scaling put a tick in Fit to 1 Page wide by 1 Page tall . ]
- On the Margins tab click in the Centre on Page Horizontally
box

- On the Sheet tab click in the gridlines box . i

° C“Ck OK Top: Header:
« Your print preview should look like this:-

Options. ..

Left: Right

E3 Microsoft Excel - 1010_test 13 %
et Previous [ oo ] [Pr\nt‘..] [Setup..‘l [Margins] [Page BraakPreview] [ Clase ] [ Help ]

~ Bottom: Eooter:

3
Center on page
St from 1010 for Mad marge
[l Horizontaliy} [ wertically

Page Setup [
| Page | Margins | HeaderFooter | sheet |

Print titles

Print.
Gridinest
d

<

Preview: Page 1 of 1 MM

If you are happy with it you can click on Print to print a copy.

Close the worksheet.



Sorting Data

You can easily sort data into ascending or descending order. There are two ways to do it
depending on your data.

If you want to sort your data into ascending or descending order by the far left column only
you can use the sort icons on the toolbar.

To do

this:-

Highlight all your data

Click on the ascending or descending icon
Your data will sort accordingly

NB: If you do not highlight all the columns containing data your sort will not work properly.

| think the best way to sort your data is to use the Data > Sort function from the menu bar,
as this gives you more control and more options for your sorts.

To do

this:-

Select Data > Sort from the menu bar

The Sort box will appear

This box allows you to sort by up to three columns in either
ascending or descending order

To set your sort order(s) click on the grey box in the first
Sort By box and select the field you wish to sort by

Click in the ascending or descending box as appropriate
You can repeat these steps for two more fields if you
require

When you have set all the sorts you require click OK

In my example | have sorted first by Tutor Group, then by
Surname and then Forename

Sort
Sart by

Tukor Group

Then by

Surnarne

Then by

Farename

Iy data range has
(%) Header row

v| @ascending;
() Descending

| (® ascending
() Descending

| (® ascending
() Descending

() Mo header row

[ Options. .. ]

[

[6]4 l [ Cancel

To remove the selected sort, select Data > Sort from the menu bar
In each box where a sort is set select None to blank the sort field

Click on OK
Your data will revert to its original format




Excel Practice 1
Open the worksheet named 10BE4
Using the functions we have covered today complete the following exercise:-

Add bold column headings to the worksheets

Ensure that each student only has one Forename

Sort the data by Tutor Group, Surname, Forename (look back over the handout if
you need a reminder)

Ensure all columns are wide enough to show all the text they contain

Add a Header in bold “Students in 10B/E4”

Add a date to the footer

Add gridlines to the sheet

Ensure all the text fits on one page

Centre the text horizontally on the page

Print out the sheet in full

Print out the students in Tutor Group 1010

Print out the students in Tutor Groups 1010 and 1007 together on one list (hint
Custom AutoFilter)



Excel Practice 2

Open the worksheet named Attendance
Using the functions we have covered today complete the following exercise:-

Add the following bold column headings:-

Admission No, Surname, Forename, DOB, Reg Group, Address 1. Address 2, Address 3, Address 4, Tel No, Date Letter sent
Ensure that each student has only one forename

Sort the students by Surname then by forename

Delete Claire Tucker and Tessa Chamberlain from the worksheet

Add a column after “Reg Group” and name it “English Group”

Add 10B/E4 as all students English Group (if you can not remember the quick way
to do this, ask!)

Ensure the columns are wide to show all the text they containing

Add a header in bold “Attendance Letters”

Add a date footer to the right section

Add gridlines to the sheet

Ensure all the text fits on one page (landscape)

Centre the text horizontally

Print out the sheet in full




